Webmacher-FAQ

 


Excel - Wie kann ich Zelleninhalt ab einem bestimmten Zeichen abschneiden?

Bewertung: 5 / 5

Stern aktivStern aktivStern aktivStern aktivStern aktiv
 

OfficeBeispiel: Sie haben in Excel eine Spalte mit Kfz-Kennzeichen. Um auszuwerten, wie oft beispielsweise BS (Stadt Braunschweig) in der Spalte vorkommt benötigt man nur die Abkürzung für den Zulassungsbezirk und der Rest inklusive Bindestrich kann wegfallen. Wie das geht, zeigen wir hier.

 

 

 

 

Um die Anzahl der Vorkommen von "BS" in der Spalte zählen zu können, arbeiten wir mit einer Hilfsspalte, in die wir nur die Abkürzung für den Zulassungsbezirk schreiben.

Dies muss flexibel geschehen, das es ja 1,2 oder 3stellige Abkürzungen für die Zulassungsbezirke gibt. Das heißt, wir müssen den Bindestrich FINDEN und dann alle Zeichen LINKS davon anzeigen lassen

 

Es sollen dann alle Zeichen LINKS vom Bindestrich in die entsprechende Zelle der Hilfsspalte geschrieben werden.

 

Beispiel:

 

Beispieltabelle: Hilfsspalte bilden, um die Zulassungsbezirke isoliert anzuzeigen

 

Zelleninhalt B2:
=LINKS(A2;FINDEN("-";A2)-1)

 

Die Formel kann in Excel dann in unserem Beispiel einfach für die ganze Spalte aufgezogen werden.

 

Wie oft die Stadt Braunschweig (BS) dann tatsächlich vorkommt, findet man einfach mit der Filterfunktion (Daten -> Filtern) raus oder man benutzt ein einfaches ZÄHLENWENN.

 

Der Inhalt der Zelle B8 lautet:

=ZÄHLENWENN(B2:B6;"BS")

 

 

 

 

 

Drucken

Kommentare  

+7 # Beidseitiges AbschneidenDaniel Schöpplein 2016-08-19 09:07
Kann ich diese Methode auch beidseitig anwenden bzw. wie? Habe es versucht doch excel schneidet scheinbar willkürlich zu wenig ab...
Antworten
+5 # Excel ab einem bestimmten Zeichen trennenElvis 2016-02-17 15:01
Was nehme ich wenn kein Zeichen sondern ein Leerzeichen an der Trennstelle ist? Leider ist Text in Spalten nicht möglich, da die Abstände unterschiedlich sind.
Antworten
+1 # Excel ab einem bestimmten Zeichen trennenElvis 2016-02-17 14:58
Wie sieht es aus wenn es kein zeichen gibt sondern nur ein Leerzeichen? Leider sind die Abstände alle unteschiedlich, so dass "Text in Spalten" nicht möglich ist.
Antworten

Kommentar schreiben

Sicherheitscode
Aktualisieren